1. hizliresim.com üzerinden resim paylaşımlarınızda resim silinir ve uyarı alırsınız. Bu yüzden farklı kaynaklara resim yükleyin.
    Uyarıyı kapat
Uyarıyı kapat
PROFİL MESAJINDAN YARDIM TALEPLERİ, BUNDAN BÖYLE İSTİSNASIZ SİLİNECEKTİR!!

Intel / NVIDIA / AMD Grafik Kartlarında HDMI Üzerinde Ses Tanıtmak

'OS X INFO KÜTÜPHANESİ' forumunda montezuma tarafından 27 Aralık 2016 tarihinde açılan konu

Konu etiketleri:

Bu Sayfayı Paylaş

  1. Ben HDMI portunu AppleIntelFrameBuffer dosyasına yapılan bir yama ile kullanabiliyorum.

    NlmHy0UQdEDoXy7zk-mTKUGpkiQ2U_0l.png

    Bu yamayı eklemeden IOReg üzerinde görünen port numaraları şöyle:
    Kod:
    AppleIntelFrameBuffer@0
    port 0x0
    connector type 02 00 00 00
    
    AppleIntelFrameBuffer@1
    port 0x5
    connector type 00 04 00 00
    
    AppleIntelFrameBuffer@2
    port 0x6
    connector type 00 04 00 00
    Bu yamayı aktif yapınca ise AppleIntelFrameBuffer@1'deki değişim şöyle oluyor:
    Kod:
    AppleIntelFrameBuffer@1
    port 0x7
    connector type 00 08 00 00
    Betiği çalıştırdığımda önce ssdt dosyasını oluştuyor, ardından port 5 ve 6 için DVI to HDMI portu olup olmadığını soruyor. Yama hem aktifken hem pasifken betikte sorulan soruda port 7'yi sormuyor.

    port 5'i onayladığımda config dosyasına AppleIntelFrameBuffer için bir yama ekliyor (betiğin eklediği yama şu şekilde: find: 01050900 00040000 87000000 replace: 01051200 00080000 06000000). Tek farkı Framebuffer ve port numarasını orijinal tutması. Bu yama HDMI görüntü aktarımının çalışması için kullandığım yama ile çatışıyor o yüzden sadece birini aktif ederek denemeler yaptım. 0105 olarak bıraktığımda HDMI kablosunu taktığım anda sistem yeniden başlıyor.

    0306 yanındaki 12 sayısının audio layout id numarası olduğunu düşünerek 03 olarak da denedim. Görüntü aktarımı yine başarılıydı ama HDMI ses sorununu çözemedim.

    Bir de betiğin oluşturduğu ssdt aktifken laptop dahili ekranı cihazı uykuya alıp uyandırmadığım sürece kapalı kalıyor.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Hepsini görmek için tıklayın...
    #11 cptnmhmt, 24 Temmuz 2017
    Moderatör tarafından düzenlendi: 24 Temmuz 2017
  2. 1. nesil amd hd5650 ekran kartında akşam deneyeceğim. bakalım nasıl bir sonuc alacagiz. voodoo ile tanıttım sesi sorun cıkmaz umarım.

    dün akşam gittim ve 1. nesil i5 işlemcili amd hd5650 aktif olarak kullandıgım laptopta sesi aktif edemedim. görüntü hdmi üzerinden tv ye gidiyor ama ses gitmiyor. applealc ile kurulu iken sadece bir adet cıkıs gösteriyor hoparlor. dediginiz işlemleri yaptım ssdt-amd vs vs diye dosyayı patched icine attı. yeniden başlattım ama ses gitmedi. başka ayar lazım mıdır bilmiyorum.
     
  3. GÜNCELLEME: Şimdi farkettim https://raw.githubusercontent.com/t...on/master/ssdt_hdef/ssdt_hdef-13-100-hdas.zip linkinden dosyayı indirmeye çalışıyor ama böyle bir dosya yok. Sanırım benim donanımım uyumlu değil bu yama için.

    command dosyasına sağ tıklayıp aç diyince açılmıyor

    "Uygun erişim ayrıcalıklarına sahip olmadığınız için “audio_cloverHDMI-130_v0.4.command” dosyası çalıştırılamadı." hatası veriyor.

    Terminalden sh komutu ile çalıştırınca çalışıyor fakat bu sefer de şöyle bir hata veriyor:

    "End-of-central-directory signature not found. Either this file is not
    a zipfile, or it constitutes one disk of a multi-part archive. In the
    latter case the central directory and zipfile comment will be found on
    the last disk(s) of this archive.
    unzip: cannot find zipfile directory in one of /tmp/ssdt_hdef-13-100-hdas.zip or
    /tmp/ssdt_hdef-13-100-hdas.zip.zip, and cannot find /tmp/ssdt_hdef-13-100-hdas.zip.ZIP, period."
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Hepsini görmek için tıklayın...
    #13 brnskn, 14 Eylül 2017
    Son düzenleme: 14 Eylül 2017
  4. arkadaslar bende hdmı görüntü var ses yok. yukarda yazılanı uyguladım indirdiğim dosyayı çalıştırınca şöyle bir uyarı alıyorum terminalde.

    p.p1 {margin: 0.0px 0.0px 0.0px 0.0px; font: 11.0px Menlo} p.p2 {margin: 0.0px 0.0px 0.0px 0.0px; font: 11.0px Menlo; min-height: 13.0px} span.s1 {font-variant-ligatures: no-common-ligatures}
    Agreement
    The audio_cloverHDMI script is for personal use only. Do not distribute
    the patch, any or all of the files for any reason without permission.
    The audio_cloverHDMI script is provided as is and without any warranty.
    File: audio_cloverHDMI-130_v0.6.command
    Release Mode
    EFI partition is mounted
    HDMI audio codec(s)
    Intel: 0x80862806
    HD4000 HDMI audio is enabled, connector edit may be required
    Verify HD4000 HDMI audio connector/s (y/n): y
    Error: more than one display connected to HD4000, patch not possible
    No system files were changed
    To save a Copy of this Terminal session: Terminal/Shell/Export Text As ...
    logout
    Saving session...
    ...copying shared history...
    ...saving history...truncating history files...
    ...completed.
    [İşlem tamamlandı]

    hdmı ses alamdım yardım tesekkürler şimdiden.
     
  5. Sistemine bağlı birden çok monitör bağlantısı var ve bu yüzden script hata vermiş. Mümkünse tek bir monitör ile dene.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Hepsini görmek için tıklayın...
  6. monitörü teke düşürüp yükledim. fakat sadece dahili hoparlörler görünmekte yine. efı clover patc görüntüsü şu şekilde
    CTwueZIHArr9wFc33AQo0UhXdLieGutK.png
    hdmı tv ses alamadım görüntü var ama ses pcı de.. ses bölümünde sadece dahili hoparlörler görünmekte.
    sistemimi şu şekilde yükledim
    [Başarılı Kurulum] Dell Inspiron 3521/5521 El Capitan 10.11.6 | Technopat Sosyal
    her şey çalışıyor bir bu kaldı. varmı yardım edebilecek bir arkadaş??
    yardımlarınız için teşekkür ederim şimdiden.
     
    #16 ankaraliadam06, 31 Aralık 2017
    Moderatör tarafından düzenlendi: 31 Aralık 2017
  7. #9 ve #11 mesajlarındaki çözümleri inceleyebilirsin.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Hepsini görmek için tıklayın...
  8. keşke şu konuyu biraz ayrıntılı anlatsan biraz yabancıyım. her sey tamam hdmı ses yok..
     
  9. Merhabalar; bende betiği çalıştırdım EFI / CLOVER / ACPI / PATCHED içinde gerekli dosyalar oluştu ama HDMI ile ilgili bir gelişme yok. Bundan sonra herhangi birşey yapmamız gerekiyor mu acaba?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Hepsini görmek için tıklayın...
  10. #9 mesajı incele.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Hepsini görmek için tıklayın...
Yükleniyor...
Yükleniyor...